cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Getting Started

ERR_EMPTY_RESPONSE

I keep getting an ERR_EMPTY_RESPONSE when I access the theme options for my website. The developer basically told me to find another hosting company. GoDaddy insists the problem isn't on their end. I have tested using Chrome, FireFox and Safari on two different Macs, Internet Explorer on a PC, and from a server in a different building on an entirely different network (different Internet carrier and all) only to have the same problem.

Has anyone resolved this issue? I don't want to leave GoDaddy, but I will if I have to.

JenC

1 ACCEPTED SOLUTION

@JenC 

 

Very strange - so obviously that needs to get changed back - but there is a setting somewhere that isn't matching up - 

 

I would try uninstalling / re-installing the theme - I really think it's something from the theme that is the issue

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

21 REPLIES 21
Super User IV

@JenC 

 

What is your domain name and can you post a screen capture including the address bar when you get the error message

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Getting Started

Screen Shot 2019-12-24 at 12.19.48 PM.png

 

Thank you for responding. My domain is coastallifestylemagazine.com and the error only occurs when I attempt to access my wordpress theme-specific theme options. 

 

T

@JenC 

 

Very strange...... if you go into File Manager on the cPanel there "should be" an error log can you see if there is anything there - In regards your the theme author saying don't use GoDaddy - there are many that say this - as they don't use the appropriate server for their needs. 

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Getting Started

Thank you again for your assistance. You have no idea how much I appreciate it!!

The error log does not include much info at all. It refers to PHP warnings about the theme's instagram widget, which is not in use on my site. I attached a .jpg copy of the instagram.php file. The error is below as are a breakout of the lines cited in the error log.

[27-Dec-2019 23:31:22 UTC] PHP Warning: Illegal string offset 'user_data' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 62
[27-Dec-2019 23:31:22 UTC] PHP Warning: Illegal string offset 'profile_pic_url_hd' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 62
[27-Dec-2019 23:31:22 UTC] PHP Warning: Illegal string offset 'user_data' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 67
[27-Dec-2019 23:31:22 UTC] PHP Warning: Illegal string offset 'followed_by' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 67
[27-Dec-2019 23:31:22 UTC] PHP Warning: Illegal string offset 'user_data' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 68
[27-Dec-2019 23:31:22 UTC] PHP Warning: Illegal string offset 'follow' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 68
[27-Dec-2019 23:31:22 UTC] PHP Warning: array_key_exists() expects parameter 2 to be array, string given in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 73

 

Instagram.php Line 62:

<img src="<?php echo esc_url($instagram['user_data']['profile_pic_url_hd']); ?>" alt="<?php echo esc_attr($params['username']); ?>" class="thb_instagram_avatar"/>

Instagram.php Line 67:

<span><?php echo thb_numberAbbreviation(($instagram['user_data']['followed_by'])); ?> <?php esc_html_e( 'Followers', 'theissue' ); ?></span>

Instagram.php Line 68:

<span><?php echo thb_numberAbbreviation(($instagram['user_data']['follow'])); ?> <?php esc_html_e( 'Following', 'theissue' ); ?></span>

<span><?php echo thb_numberAbbreviation(($instagram['user_data']['followed_by'])); ?> <?php esc_html_e( 'Followers', 'theissue' ); ?></span>

 

I installed FireFox Developer, visited my problem page, and now I wonder if the issue is actually a problem with the header and redirects. (See attachments: FireFoxDeveloper 1 & 2). I have an SSL on my site, however, as per GoDaddy's instructions, I installed my site on http://coastallifestylemagazine.com. GoDaddy automatically redirects my http:// site to https:// yet the theme is calling to the needed theme-specific Theme Options pages on http:// and throwing a 302 error. I read that I could change the 302 redirect to a 307, which would basically redirect the redirect. How I do this is beyond me. 😞

Chrome Developer Tools essentially returned the same info, albeit more basic. See: ChromeDeveloperTools(1).

 

Thank you again for your time.
Jen

Getting Started

Thank you again for responding. You have no idea how much I appreciate your assistance!

 

There is not much info in the error log. It keeps reporting an Instagram widget plugin error. The plugin came canned with the theme – I did not install it. For the record – I am not using it and not attached to it any way.

[28-Dec-2019 02:06:11 UTC] PHP Warning:  Illegal string offset 'user_data' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 62

[28-Dec-2019 02:06:11 UTC] PHP Warning:  Illegal string offset 'profile_pic_url_hd' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 62

[28-Dec-2019 02:06:11 UTC] PHP Warning:  Illegal string offset 'user_data' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 67

[28-Dec-2019 02:06:11 UTC] PHP Warning:  Illegal string offset 'followed_by' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 67

[28-Dec-2019 02:06:11 UTC] PHP Warning:  Illegal string offset 'user_data' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 68

[28-Dec-2019 02:06:11 UTC] PHP Warning:  Illegal string offset 'follow' in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 68

[28-Dec-2019 02:06:11 UTC] PHP Warning:  array_key_exists() expects parameter 2 to be array, string given in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/widgets/instagram.php on line 73

 

A screenshot of the full Intagram.php file is attached. Below is a blowout of the offending lines.

 

Instagram.php Line 62

<img src="<?php echo esc_url($instagram['user_data']['profile_pic_url_hd']); ?>" alt="<?php echo esc_attr($params['username']); ?>" class="thb_instagram_avatar"/>

Instagram.php Line 67

<span><?php echo thb_numberAbbreviation(($instagram['user_data']['followed_by'])); ?> <?php esc_html_e( 'Followers', 'theissue' ); ?></span>

Instagram.php Line 68

<span><?php echo thb_numberAbbreviation(($instagram['user_data']['follow'])); ?> <?php esc_html_e( 'Following', 'theissue' ); ?></span>

Instagram.php Line 73

<?php if (array_key_exists('data', $instagram)) { foreach ($instagram['data'] as $item) { ?>

 

I installed FireFox Developer and now I wonder if the issue is with the header and redirects. My site is installed on http://coastalllifestylemagazine.com and I have an SSL. GoDaddy redirects the http:// to https://.  When I attempt to access the theme-specific Theme Options page, it throws a 302. I read I can change the 302 to a 307 so the redirect is basically redirected back to http://. I have no clue how to do this. (See FireFoxDeveloper 1 & 2) Chrome Developer Tools report the same, albeit basic, information. (See ChromeDeveloperTools 1).

 

Thank you again for all of your help!!

Instagram-php(1).jpgInstagram-php(2).jpgFireFoxDeveloper(1).jpgFireFoxDeveloper(2).jpgChromeDeveloperTools(1).jpg

 

@JenC

I see there is something about cross site origin. I can look at thus more over the weekend
I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Getting Started

@PL281 

 

I don't even know what that means. 🙄

Thank you very, very much!!

@JenC 

 

In your cPanel account can you go to PHP Settings and where it says select version near the top  switch it from 7.3 to 7.2 - there are some differences in some of the underlying elements between the 2 - see if that makes a difference

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Getting Started

@PL281 

 

- Thank you. I downgraded PHP to 7.2 only only to no avail. I installed the Theme Check plugin and it returned the below result. Where my issue is with Theme Options - do you think this could have anything to do with it? Thank you again!
*EDITED: I am not using a child theme as the child theme does not work. I am using the parent theme.*

 

  • WARNING: Your theme appears to be in the wrong directory for the theme name. The directory name must match the slug of the theme. This theme's correct slug and text-domain is the-issue.
    (If this is a child theme, you can ignore this error.)

 

  • REQUIRED: inc/admin/welcome/fuelthemes.php. Themes should use add_theme_page()for adding admin pages.

Line 814: add_submenu_page( 'thb-product-registration', 'Registration', 'Registration

Line 817: add_submenu_page( 'thb-product-registration', 'Plugins', 'Plugins', 'edit_t

Line 820: add_submenu_page( 'thb-product-registration', 'Demo Import', 'Demo Import',

Line 823: add_submenu_page( 'thb-product-registration', 'Theme Options', 'Theme Optio

  • REQUIRED: inc/admin/welcome/fuelthemes.php. Themes should use add_theme_page()for adding admin pages.

Line 811: add_menu_page( Thb_Theme_Admin::$thb_theme_name, Thb_Theme_Admin::$thb_them

@JenC 

 

are you using a child theme??

Can you post a screen capture from the cPanel file manager of your theme folder

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Getting Started

The Child Theme threw the error in question immediately upon install, so I skipped it. This probably should have been my first sign. 😞

Attached is a screenshot of the WPContent folder as well as a snapshot of my plugins. Theme Options was working fine after I installed each plugin as I was able to enable the Pinterest social icon. 

Over the weekend I noticed something that struck me as odd, so I am attaching FOUR MORE screenshots. 🙂

Within the Wordpress Dashboard, I have a menu options for my theme - The Issue - which includes a submenu with the following submenu options: Plugins, Demo Import, Theme Options. When I launch Plugins and Demo Import - I am directed to admin.php?page=thb-demo-import - or - page=thb-plugins. When I launch Theme Options, I fail at ot-theme-options after being redirected from thb-theme-options. I used the Check Theme plugin (on a dev site) and it returned the following:

  • REQUIRED: inc/admin/welcome/fuelthemes.php. Themes should use add_theme_page() for adding admin pages.

Line 814: add_submenu_page( 'thb-product-registration', 'Registration', 'Registration

Line 817: add_submenu_page( 'thb-product-registration', 'Plugins', 'Plugins', 'edit_t

Line 820: add_submenu_page( 'thb-product-registration', 'Demo Import', 'Demo Import',

Line 823: add_submenu_page( 'thb-product-registration', 'Theme Options', 'Theme Optio

  • REQUIRED: inc/admin/welcome/fuelthemes.php. Themes should use add_theme_page() for adding admin pages.

Line 811: add_menu_page( Thb_Theme_Admin::$thb_theme_name, Thb_Theme_Admin::$thb_them

^^^

I also referred back to my user documentation to confirm the PHP requirements are set correctly. 

The theme developers recommend Max Upload Size = 100M, however, I cannot bump it beyond 64M. (Further in the documentation, the developers note that at a minimum it should to be set at 32M.) Even though I have it set to 128M in the cPanel, the theme is only acknowledging 64M I am guessing because, according to the GoDaddy popup, post_max_size should be larger than upload_max_filesize and smaller than memory_limit.
^^^

WPContent.png

Plugins.png

'The Issue' Submenu.png

'The Issue' submenu - Plugins.png

'The Issue' submenu - Demo Import.png

'The Issue' submenu - Theme Options.png




@JenC 

 

What happens if you change the ot to thb on that other URL ??

 

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Getting Started

When I change the ot to thb, it says - Sorry, you are not allowed to access this page.

 

Screen Shot 2019-12-30 at 9.52.26 AM.png

@JenC 

 

In the /wp-content/themes folder - what is listed there??

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Getting Started

wp-content\themes\

theissue
twentynineteen

twentyseventeen

twentysixteen

twentytwenty

index.php

@JenC 

Based on a previous post you did - I believe the folder name should be the-issue with a hyphen

 

You may have to re-active the theme after changing that - while it "shouldn't" mater - it's possible it does

 

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Getting Started

No kidding!?!? Can I just change this in File Manager?

@JenC 

 

Yes you can update that via the file manager

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

Getting Started

it didn't really like that. 

 

Fatal error: Uncaught Error: Call to undefined function thb_add_short() in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/vc_templates/thb_accordion.php:20 Stack trace: #0 /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/plugin.php(88): require_once() #1 /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/plugin.php(52): TheIssue_plugin->run_plugin() #2 /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/plugin.php(32): TheIssue_plugin->__construct() #3 /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/plugin.php(118): TheIssue_plugin::get_instance() #4 /home/gcbclm/public_html/wp-includes/class-wp-hook.php(288): thb_theissue_plugin('') #5 /home/gcbclm/public_html/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters('', Array) #6 /home/gcbclm/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #7 /home/gcbclm/public_html/wp-settings.php(507): do_action('after_setup_the...') #8 /home/gcbclm/public_html/wp-config.php(106): require_once('/home/gcbclm/ in /home/gcbclm/public_html/wp-content/plugins/theissue-plugin/inc/vc_templates/thb_accordion.php on line 20

There has been a critical error on your website.

Learn more about debugging in WordPress.

@JenC 

 

Very strange - so obviously that needs to get changed back - but there is a setting somewhere that isn't matching up - 

 

I would try uninstalling / re-installing the theme - I really think it's something from the theme that is the issue

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post