cancel
Showing results for 
Search instead for 
Did you mean: 

Web contact form stopped working

I have a Contact page on my domain with a form that I wrote myself in Perl. It has worked for years but stopped last week. I have put triggers (print to screen) at different points to confirm that it is successfully passing through the Main Logic section, Input section, Field Test section, Sendmail section using $mailprog = '/usr/lib/sendmail -t', and the final Thank You section. This script has worked for years. Now I can only receive mail through web access if people already know my address. What happened? Is your mail server queue stuck? Did you change your spam tolerances? Do I need to change my mail header? Thanks for any help. -Ron

7 REPLIES 7
Helper V
Helper V

Re: Web contact form stopped working

You should configure Spam Assassin and cross-check it.

Please give it a +1 and also click "Mark As Accepted Solution" if you find it satisfactory. Thanking You With Regards | Harry Parmar

Re: Web contact form stopped working

Thanks to Jason in Support for his assistance. My site was hacked through a rewrite in the root htaccess file to other php files which are not mine, and the relay server marked me as a bad website. I'll be changing passwords more often and using Captcha on all forms.

New

Contact Form / PHP is not sending mail to some domain

Hi

I am getting below message while sending a mail to my domain through php file.

I am getting Email has been sent!! but i am not getting any mail.

 

Please help me to fix.

 

SMTP -> FROM SERVER:220-a2plcpnl0783.prod.iad2.secureserver.net ESMTP Exim 4.87 #1 Sun, 08 Jan 2017 08:56:53 -0700 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.
SMTP -> FROM SERVER: 250-a2plcpnl0783.prod.iad2.secureserver.net Hello a2plcpnl0783.prod.iad2.secureserver.net [107.180.108.9] 250-SIZE 52428800 250-8BITMIME 250-PIPELINING 250-AUTH PLAIN LOGIN 250-STARTTLS 250 HELP
SMTP -> FROM SERVER:250 OK
SMTP -> FROM SERVER:250 Accepted
SMTP -> FROM SERVER:354 Enter message, ending with "." on a line by itself
SMTP -> FROM SERVER:250 OK id=1cQFq2-000rdv-2M
Email has been sent!!

 

 

New

Can't receive Emails on my admin account from my website's contact us page

I can't receive emails on my admin account from my websites's contact us page. Can anyone help me in?

Re: Web contact form stopped working

So what was the solve?

I have this exact thing happen to me.

I went and deleted the htaccess files + the strange PHP files on my root.

My form still doesn't send.

If the site got flagged, then how to get it unflagged so the form can work again?

 

Solve: seems that a call to Support is necessary to have the web email server unflagged (could've just posted that above in the first place to be clear lol)

New

Contact form not sending email script

I have this script that I have been using and on this site I have noticed most of my emails don't come through. Especially sent from phones. Could someone look at this script and see if there could be a change I could do to make it work?

Thanks

 

<?php
 
if(isset($_POST['email'])) {
 
    
 
    // EDIT THE 2 LINES BELOW AS REQUIRED
 
    $email_to = "sales@MY.us";
 
    $email_subject = "MY Sales";
 
    
 
    
 
    function died($error) {
 
        // your error code can go here
 
        echo "We are very sorry, but there were error(s) found with the form you submitted. ";
 
        echo "These errors appear below.<br /><br />";
 
        echo $error."<br /><br />";
 
        echo "Please go back and fix these errors.<br /><br />";
 
        die();
 
    }
 
    
 
    // validation expected data exists
 
    if(!isset($_POST['first_name']) ||
 
        !isset($_POST['last_name']) ||
 
        !isset($_POST['email']) ||
 
        !isset($_POST['telephone']) ||
 
        !isset($_POST['comments'])) {
 
        died('We are sorry, but there appears to be a problem with the form you submitted.');      
 
    }
 
    
 
    $first_name = $_POST['first_name']; // required
 
    $last_name = $_POST['last_name']; // required
 
    $email_from = $_POST['email']; // required
 
    $telephone = $_POST['telephone']; // not required
 
    $comments = $_POST['comments']; // required
 
    
 
    $error_message = "";
 
    $email_exp = '/^[A-Za-z0-9._%-]+@[A-Za-z0-9.-]+\.[A-Za-z]{2,4}$/';
 
  if(!preg_match($email_exp,$email_from)) {
 
    $error_message .= 'The Email Address you entered does not appear to be valid.<br />';
 
  }
 
    $string_exp = "/^[A-Za-z .'-]+$/";
 
  if(!preg_match($string_exp,$first_name)) {
 
    $error_message .= 'The First Name you entered does not appear to be valid.<br />';
 
  }
 
  if(!preg_match($string_exp,$last_name)) {
 
    $error_message .= 'The Last Name you entered does not appear to be valid.<br />';
 
  }
 
  if(strlen($comments) < 2) {
 
    $error_message .= 'The Comments you entered do not appear to be valid.<br />';
 
  }
 
  if(strlen($error_message) > 0) {
 
    died($error_message);
 
  }
 
    $email_message = "Form details below.\n\n";
 
    
 
    function clean_string($string) {
 
      $bad = array("content-type","bcc:","to:","cc:","href");
 
      return str_replace($bad,"",$string);
 
    }
 
    
 
    $email_message .= "First Name: ".clean_string($first_name)."\n";
 
    $email_message .= "Last Name: ".clean_string($last_name)."\n";
 
    $email_message .= "Email: ".clean_string($email_from)."\n";
 
    $email_message .= "Telephone: ".clean_string($telephone)."\n";
 
    $email_message .= "Comments: ".clean_string($comments)."\n";
 
    
 
    
 
// create email headers
 
$headers = 'From: '.$email_from."\r\n".
 
'Reply-To: '.$email_from."\r\n" .
 
'X-Mailer: PHP/' . phpversion();
 
@mail($email_to, $email_subject, $email_message, $headers); 
 
?>
 
 
 
<!-- include your own success html here -->
 
 
 
Thank you for contacting us. We will be in touch with you very soon.
 
 
 
<?php
 
}
 
?>

Some emails missing - Drupal Webforms

As of recently (just over one week), there are missing emails form my Drupal webforms. I have 13 individual webforms across 3 sub-domains, with some failing to send all email. There is no rhyme or reason behind it, it's just random ones that get dropped, and never go through. When I identify these missing submissions, I open them and try to send again (and again, and again..) but they never come through. What's going on with this?? I tried calling last week and was told my site was compromised, but that has been identified and cleaned up, yet the problem persists. I need this permanently fixed ASAP. Somebody please email me back.

Kevin