cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

-bash: sudo: command not found

I am trying to turn my account into root, by the command "sudo su -", but I am informed this.

I'm using ssh.

 

http://i.imgur.com/yjhXbMw.png

8 REPLIES 8
Helper V

Re: -bash: sudo: command not found


@andersonhese wrote:

I am trying to turn my account into root, by the command "sudo su -", but I am informed this.

I'm using ssh.

 

http://i.imgur.com/yjhXbMw.png


@andersonhese

 

Hello there,

I had this issue gosh some time back...... (sorry to say longer then my memory goes)..... however I believe it had to do with the shell fork bomb protection....... login to server, security it is there. Try disabling this , then try again. You can always enable it when you are done.

Hope this helps!

 

Mrsroadrunner Photography
New

Re: -bash: sudo: command not found

@andersonhese @mrsroadrunner

 

Hi, I'm having the same issue. But I don't understand part of the response from @mrsroadrunner's :

 

however I believe it had to do with the shell fork bomb protection....... login to server, security it is there. Try disabling this , then try again. You can always enable it when you are done.

ount into root, by the command "sudo su -", but I am informed this.

When you say "login to server", are you talking about connecting via SSH? Or using Godaddy's portal? Either way, I can't find anything about shell fork bomb protection.

 

Any help is appreciated. Thanks!

Helper V

Re: -bash: sudo: command not found


@arvn wrote:

@andersonhese @mrsroadrunner

 

Hi, I'm having the same issue. But I don't understand part of the response from @mrsroadrunner's :

 

however I believe it had to do with the shell fork bomb protection....... login to server, security it is there. Try disabling this , then try again. You can always enable it when you are done.

ount into root, by the command "sudo su -", but I am informed this.

When you say "login to server", are you talking about connecting via SSH? Or using Godaddy's portal? Either way, I can't find anything about shell fork bomb protection.

 

Any help is appreciated. Thanks!


@arvn

Hello there Arvin,

If you go into your server, then go to the security tab..... you might be able to do it through SSH but I have no clue how to disable the feature there?

Wish you well!

Mrsroadrunner Photography
New

Re: -bash: sudo: command not found

I have the same problem. But I am not sure where I could find "login to server", and where are the Sudo options? 

Community Manager
Community Manager

Re: -bash: sudo: command not found

Hi @peymmo, what type of server are you trying to access?  VPS?  Dedicated?  

 

MPC

Re: -bash: sudo: command not found

Hello, 

 

I have the same issue, Anyone Get the solution on this ?  

Re: -bash: sudo: command not found

This is an old thread, but it has the exact same question that I am looking for. 

I did an additional search and found this:

https://www.godaddy.com/help/enable-adminroot-access-managed-or-fully-managed-12270

 

I'm going to try it and let you know.

 

Solution

Re: -bash: sudo: command not found

Well, indeed, it did not work.  As I suspected, you have to have your own dedicated or managed server in order to  get root access.  I am on a Linux cPanel hosting, but it is shared. 

 

So   hopefully I'll be able to accomplish what I'm  trying to do without root access.  We will see. 

This is posted FYI.