• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution

    FTP connected but unable to transfer files

    I'm trying to transfer files using WinScp, i was able to login to root folder, when i try to transfer a file, the progress showing 100% but speed is always 0 B/s. At the end the file on the remote server is 0 KB.

    1 ACCEPTED SOLUTION

    SOLUTION for FILEZILLA users

    I had this issue (upload aborts; file is created or overwritten on server as a 0-byte file)

     

    The solution was Filezilla->Site Manager->[Your Site]->Charset->Force UTF-8

     

    It is set to "Autodetect" by default.

     

    The "Charset" tab is found on the same page that you enter hostname, protocol, port etc.

    View solution in original post

    29 REPLIES 29
    Retired
    Not applicable

    Hi @dialoghub,

    first have a read of any problems here: https://winscp.net/eng/docs/messages

    No, Please check it @Retired. I am sure that is the fault of the server. I experienced the same problem. I tried with various operating system and various FTP clients and configurations. It didn't work at all.

    Retired
    Not applicable

    @MessengerAppDow,


    @MessengerAppDow wrote:

    No, Please check it @Retired. I am sure that is the fault of the server. I experienced the same problem. I tried with various operating system and various FTP clients and configurations. It didn't work at all.


    ....and what is your Domain name so I can check please?

    @Retired

     

    Thank you!. Mine is  http://messengerappdownload.com/

    Retired
    Not applicable

    Hi @MessengerAppDow,

    Your ftp is not connected, or at least not active. I would very carefully go back over the configuration docs regarding your type of site and hosting. It's possible you are correct and it is a server issue in which case I would phone or contact support. But recheck your settings first to save a red face.

    @Retired Yes I tried with various of settings in different ftp client. The problem is exactly as @dialoghub mentioned, and it persists for 3 days.

    Retired
    Not applicable

    @MessengerAppDow@dialoghub,

    Support will be able to access your site, take a look at your settings and probably see or advise what's wrong. I can only run a few check, which I did to see if your ftp service is active. I saw it wasn't. Ftp also needs to be set up server side as well as client side. 

    Support are the only guys here who can help, unless you gave account access to a pro member here.

    sorry! 

    Hey @MessengerAppDow@dialoghub,

     

    I'm just curious, were you both trying to use FTP or SFTP? Reason I ask is because FTP isn't enabled on Managed WordPress Hosting plans (which I assume you're both using). That would also explain why @Retired wouldn't be able to find FTP protocols enabled on the server.

     

    If you are actually using Managed WordPress, try the help article I linked above to connect to your sites. If there's still an issue moving files over, then the previous suggestion to contact support would be the best route to go so our hosting team can assist further. 

     

    CG - GoDaddy | Community Moderator
    24/7 support available at x.co/247support

    I'm using SFTP with port 22. As i mentioned in my previous situation, i was able to login to ftp and surf all the files and directories. I can copy the files from server to local PC, just it failed to transfer file to server.

     

    File on server is zero size, and FTP client disconnected from server

    This is exactly the issue I'm facing and tech support team is telling me that I have internet connection problem whereas I'm able to access other domains easily on the same internet connection. Help Please!!!

    @RetiredI try different settings and try Filezilla too, it is same result. Please help as i not able to upload any files. thanks

     

    plus360mobile.com

    I have this same exact issue with 2 separate clients, both of whom are using Managed WordPress Hosting. I spent over an hour on the phone with tech support this past week trying to resolve this issue and they could not help me.

     

    Despite GoDaddy's documentation stating otherwise, I'm unable to edit .htaccess, wp-config.php, or the contents of wp-content directory. I can download these files but, as soon as I attempt to upload the edited files, my FTP program hangs with a 0 KB/s speed and then disconnects. When I reconnect, the file I attempted to upload appears on the server as 0 KB in size. I can change the file names of .htaccess, wp-config.php, and theme files. I can change their permissions. But, as soon as I attempt to upload them, the upload fails.

     

    And I'm definitely connected, using SFTP port 22, because I can upload other non-WordPress related files, either new files or overwriting existing files.

     

    Even more strange, I can download wp-config.php, rename it to test.php or test.html, and when I attempt to upload it, it fails (in any directory I try to upload it to). What does work? If I remove parts of the wp-config.php code from test.php or test.html. For example, if I just keep the top portion of the wp-config code in the file (the section with database connection variables), it will upload. As soon as I add the section containing the salts, the file fails to upload.

     

    This is a server security issue that needs to be resolved. The only option for editing theme files currently is through WordPress's Theme Editor which in and of itself is a security risk. It's actually why I've been attempting to update my client's wp-config.php file: to turn off access to the Theme Editor!

     

    Edit: The documentation that says what files should be editable but aren't:

    https://www.godaddy.com/help/limits-on-editing-files-8943

    I am experiencing this very same issue with WordPress managed hosting and it is very very frustrating.

     

    @manojkumarcdoThis does not resolves issue, your solution is not related to WP managed hosting.

    Hi @acamilicko

     

    Follow the link below. 
     
    Thank You.

     @manojkumarcdo

    Man, we already know how to connect to SFTP of managed WordPress server, may seem you didn't read above what is the issue. Like I am saying I can't steer the car driving wheel, and you say: You have to enter the car first. Man, I entered the car, but I can't steer the wheel.

    I have the very same issue as people above, so connected to SFTP, can download all, but when I go to upload any file, it says: Connecting, connected, starting transfer, and then freezes for 20-30 seconds, does 2 more repeats of the same process and then fails to upload file. If I am replacing existing file on the server, it leaves at FTP file with 0 bytes, empty file, and in that way, if that was some theme file, it destroys theme.

    FileZilla reports "Connection closed due to software error"

    That may be helpful, maybe...

    The issue not yet solve and it's more than a week just a simple ftp issue.

    Godaddy's support should address the issue quickly.

    Helper IV

    Hi @dialoghub

    To log in through FTP (FileZilla).  You should know the primary credentials of your web hosting.  Follow the video tutorial below.

     

    https://youtu.be/J2ai0HvMVd8

     

    Thank You.

    New

    FileZilla --> Edit --> Settings --> SFTP: Check "Enable compression"

    SOLUTION for FILEZILLA users

    I had this issue (upload aborts; file is created or overwritten on server as a 0-byte file)

     

    The solution was Filezilla->Site Manager->[Your Site]->Charset->Force UTF-8

     

    It is set to "Autodetect" by default.

     

    The "Charset" tab is found on the same page that you enter hostname, protocol, port etc.

    View solution in original post