cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Highlighted
New

Both my sites in domain and subdomain are in a <frame>. How do I fix this?

Hi, I wanted to manage my DNS and guess something went wrong (also the UI may have changed since the last time I managed my DNS maybe something is missing, I don't know). 

Now whenever I navigate to my domain name or its subdomain what I see is the page I am supposed to see but in a html frame. Here are my settings;

Domain Manager_20190722000612.png

 

You might have to right-click the image and choose "Open Image in a new tab" to see the enlarged version of the image (I don't know if it's going to work though).

 

As you can see in the image, I forwarded the sphinx subdomain to http://88.xx.xx.xx:8080 using a permanent (300) forward and set the forward to be with masking (I did the same with the domain, except I use the default port instead of 8080). I also had to give at least a title, a description or keywords to the masking (I use the title sphinx). Then I saved everything. Now whenever I go to http://sphinx.mydomain.tld/ or even adding a path (like this: http://sphinx.mydomain.tld/my/path?query=string) it is showing me the page I want to see but everything is in a frame. below is the source code of the page that proves that everything is in a <frame> (IP is censored obviously):

 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
<html>

	<head>
		<title>sphinx</title>  
		<meta name="description" content="">
		<meta name="keywords" content="">
	</head>
	<frameset rows="100%,*" border="0">
		<frame src="http://88.xx.xx.xx:8080/" frameborder="0" />
	</frameset>

</html>

not only that, but every internal links on any page of my sites (domain and subdomain) contain my servers' IP address displayed in clear instead of the domain name. That wasn't the case before and is not the way I want it to work. Also the values above (in the picture) for the '@' record and the 'sphinx' record are not my IP addresses but seems to be a godaddy IP address I don't know what it is doing there!

 

How can I tell godaddy to permanently forward my domain with masking without using any frame and use my domain name in every links on the site?

1 REPLY 1
Super User III Super User III
Super User III
Solution

Re: Both my sites in domain and subdomain are in a <frame>. How do I fix this?

Masking relies on obsolete code that can cause problems with modern browsers.  This may sound confusing but you can not redirect and mask at the same time, to use 301 or 302 redirect masking needs to be off otherwise with it on a frame is used instead.

 

The simple solution would be to turn off masking and just redirect.  But to properly connect the domain the server would need to be configured what to do with requests on that domain, and the domain would need to be pointed instead of forwarded.