Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

TXT record not found

When I add a TXT record, it appears to add properly to my domain.  


However, seemingly regardless of how much time has passed, when I search for the TXT record, it is never found.  


If I run

host -t txt

it returns my has no TXT record 


But if I run this for other domains, it returns results, so I believe the command is valid.  


I have waited over 72 hours for the change to propagate.  


What should I be looking for?  I only use GoDaddy for DNS, I host the site myself.  




Re: TXT record not found

Resolved my own issue.  I spent days on this and figured out I was just entering the TXT name entry incorrectly.  


Re: TXT record not found

@pullyjw wrote:

Resolved my own issue.  I spent days on this and figured out I was just entering the TXT name entry incorrectly.  

Hi, can you be more specific how you solved the issue?

Re: TXT record not found


In the host field enter your subdomain.

exp. xxx.yyyy.zzz


txt vale=assignyourtxtvalue


Re: TXT record not found


I had this same issue. I transferred my domain from a different host. After the transfer my Amazon SES domain verification (the TXT record) and the DKIM records (CNAME) were no longer verified - even after entering them exactly as I had from the previous DNS host into the GoDaddy DNS area.


When I performed a DNS check in a command-line tool (Mac Terminal or Windows cmd) using the following code:

nslookup -type=TXT

I received the following result:

** server can't find NXDOMAIN


As I discovered (and as others have mentioned) this is because GoDaddy appends your domain to the end of the TXT Name entry. So if you enter your TXT Name as:

It will actually be recorded as:


(this means Amazon SES can't find the record - because they're searching for the - hence it cannot be verified)


You can verify this by checking for the double-domain record by doing an NSLOOKUP. For your TXT record:

nslookup -type=TXT

Be sure to replace with your actual nameserver. Find your name server:

nslookup -type=NS


If your domain name has been repeated, this should return something like:

Address: (the IP address) text = "your_text_code_will_appear_here"


And to search for the DKIM:

host -t CNAME


Other forums suggest placing a period '.' at the end of your domain to prevent GoDaddy from automatically adding your domain again, but I have found this did not work with GoDaddy.


Instead, you must just remove your domain from the TXT Name and the CNAME Name. Instead of what Amazon SES Management Console suggests:

TXT Name*:



TXT Name*: _amazonses
The same applies for the DKIM CNAME entries. Instead of:
Enter this instead:
Name: big_long_code_here._domainkey
The values remain unchanged. I've seen some forum stating you must enter your values encased within double-quotes (" "). But I did not do this and it worked out fine - I do however have my gmail SPF record TXT value encased within double quotes ¯\_(ツ)_/¯.
Wait a while for these to propagate, then check again with an NSLOOKUP (this time not repeating your domain twice):
For TXT record:
nslookup -type=TXT
For a specific CNAME (DKIM) record:
host -t CNAME
(replacing the DKIM code for each of the three records you want to check).
Or, use an online DNS checking tool (like to see if your changes are beginning to propagate worldwide (perform a TXT search entering into the text input / or perform the DKIM search by entering If they are, it should be a matter of time for Amazon SES to verify your TXT and DKIM entries.

This worked for me, hope it helps - I've tried to explain it very simply for people like me (those who don't really know what they're doing and are learning as they go).
(p.s. Amazon 'paid' Support were not able to provide me with this information (I guess each DNS host is slightly different) I had to do it through trial-and-error).

Re: TXT record not found

Thank you for this solution.

Works for me.

Re: TXT record not found

THANK YOU SO MUCH FOR THIS!! This was EXACTLY what I needed. If I hadn’t stumbled upon your post, I would’ve been stuck with this problem for a while.
I’ve sent a feedback email on the aws instructions page regarding this issue, and I hope they’ll update it to reflect your post. Thanks again for your post!