Showing results for 
Show  only  | Search instead for 
Did you mean: 

Trouble setting up Exchange account in a Mac

Hi, for several weeks now, I have not been able to complete the process of adding an email account to my Mac, that worked flawlessly for years. I am running Mojave 10.14.2.

I found this workaround in one of these forums, and tried it, but it did not work for me. Tried replying to the post, but the "reply" button was grayed out. Frankly, very annoying. Here I am posting this whole thing below.


How I fixed the issue of configuring Office 365 email on Mac Mail

Hi everyone,


I would like to share the solution that worked for me in setting up office 365 e-mail on Mac Mail app.


In the internal & External URL I put the following:


You will get a message "unable to verify account e-mail and password"  ... click "sign in" and continue anyway.


You will see the services that you want added. Add them and finish the setup.


Now the email will be added, and you will see the server trying to connect. and guess what? it did! I can send and receive emails with no issues.


A half hour call to Godaddy support couldn't fix this for me.


Please share if it works for you too.


Happy emailing!




The process stops after it authenticates my credentials (see screencapture), and presents me with the features I would like to add, then... nothing.

Screen Shot 2019-01-11 at 8.50.40 AM.png


I have spent well over 1.5 hours with Godaddy support and they could not figure out what is the problem, or actually they said it was not their problem, but Mac's.

Please help.




This is the capture that I intended to include in the post.Screen Shot 2019-01-11 at 8.50.40 AM.png

My "answer" is more along the lines of  "throwing in the towel" vs. a solution, but I had the same issue and disliked used the web interface.   I eventually conceded that my time was money, gave up and bought "Outlook" for Mac and it's worked from inception. (using version 16.22)   What's been annoying is that when a mail link is clicked on from outside source (eg to send mail to that address) the default client that pops up is apple mail. I'm sure there's likely a fix for this but haven't bothered looking.