cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Getting Started

"wordpress not sending emails" (in quotes bc not really wordpress issue?)

"wordpress not sending emails" (in quotes bc not really wordpress issue?)

 

For a new domain (using 'deluxe' cpanel hosting) this issue 1st showed itself when setting up a self-hosted wordpress install. Installed fine, then went to change the admin's email and never got the confirmation email to complete the change. [ note- email addresses for this domain, set up in Workspace function properly, ie can send/receive via normal mail apps on desktop/phone etc ]

 

Didn't notice this issue when 1st installing WP as the admin email used was outside the domain and that worked fine.

 

Doing research, found a plugin Check Email ( wordpress.org/plugins/check-email/ ) and running tests, emails to outside the domain go thru (and From shows as current WP admin) but if trying to send a test to an address for the domain, it never gets to our mailbox and no errors or warnings. Did a fresh WP install, using an admin email of our new domain and same results.

 

So trying to narrow it down, took WP out of the equation and wrote a simple php file to test and this byitself shows the same - works going outside the domain and doesnt work to the domain. (at 1st thought maybe using 'hello@' might be being caught by some sort of spam filter, so changed address to something else and all same results)

 

the code:
<?php
     $from = "theaddy@thedomain.com";
     $to = "theaddy@thedomain.com"; /* anotheraddy@anotherdoamin.com works */
     $subject = "PHP Mail Test script";
     $message = "This is a test to check the PHP Mail functionality";
     $headers = "From:" . $from;
     if ( mail($to,$subject,$message, $headers) ) {
          echo "from: " . $from . "<br />";
          echo "to: " . $to . "<br />";
          echo "Test email successfully accepted for delivery.<br />";
     } else {
          echo "nope.<br />";
     }
?>

 

One other note, on this deluxe cpanel hosting account we are hosting other domains with WP installed the same way, and everything works as expected - it's just this new domain that we just got a few weeks ago.

 

Any/all insight is greatly appreciated.
Thank you!

- - -

1 ACCEPTED SOLUTION

@uncleTC 

 

Since you mentioned the MX records are set to secureserver.net (GoDaddy WorkSpace Email) I would change the mail delivery for the domain in question to remote and it "should" work / fix the issue

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

8 REPLIES 8
Super User IV

@uncleTC 

 

Did you check the MX settings in cPanel to see if they are set to local or remote - 

Local = Mail Hosted on cPanel

Remote = Mail Hosted anywhere else

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

@PL281 , thanks for the reply.

 

All of the email accounts are setup thru Workplace emails.  But checking cpanel, all domains (looking at Zone Editor - pls let me know if I shold be looking elsewhere) are set with TTL: 14400, Class: IN, Type: MX, Priority: 0.

 

These settings are the same for all of the domains we're hosting on this account. All of the other domains, the emails are working as expected, this one new domain is the only one acting this way.

 

 

 

@PL281   if looking at the DNS settings for the domain, I do see two entries for MX:

mailstore1.secureserver.net (Priority: 0)

smtp.secureserver.net (Priority: 10)

 

and looking at the other domains they have these entries as well (except the main domain that the hosting acct is linked to only has the usual smtp.secure... entry)

@uncleTC

This is not the dns setting but rather the mail routing setting in cpanel
I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

@PL281  Thanks.

 

Looking at Email Routing, all domains except the main domain that the hosting account is link to are set to:

Automatically Detect Configuration : Local (recommended)

 

The main domain (not the one in question) is set to Remote.

Those other domains do work as set. Just not this new one.

@uncleTC 

 

Since you mentioned the MX records are set to secureserver.net (GoDaddy WorkSpace Email) I would change the mail delivery for the domain in question to remote and it "should" work / fix the issue

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

@PL281  🙌  that looks like it will do it.

 

So forcing it to Remote, instead of letting it Automatically Detect.

 

@PL281 thanks for your help, I really appreciate it!

update - tested with both just the php test file and now also with WP contact form (Jetpack) and both worked, emails received.

 

btw - when I called tech support they tried steering me to this being a WP configuration issue (and of course they have a pay service to have them diagnose), even tho I told them that I had factored out WP by writing a stripped down php test file (see code above). I guess "using wordpress contact form" ranks high on their support issues database.

 

big Thanks to the Community Forums!!!