cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution
loopglobal
Novice

ZipArchive need to be enable

Hello,

 

I have purchased a theme from themeforest and installed and I see this notice.

 

ZipArchive
 
Not installed - ZipArchive is required for importing content. Please contact your server administrator and ask them to enable it.
 
So please install this so that I can enable this.
 
thanks
37 REPLIES
GoDaddy Pro Proficient
GoDaddy Pro Proficient
Solution

Re: ZipArchive need to be enable

What kind of hosting do you have?  Do you have a shared linux host, and have access to cPanel?

 

If so, you should be able to do this yourself.  Just log in to your cPanel, and click on the icon labeled "PHP PEAR Packages" (in the Software section).  Next, in the search box (underneath the "Find a PHP Extensions and Applications Package" heading, type in "zip" and click the Go button.  On the next page, you should see a listing for Archive_Zip - simply click on the Install link on the right hand side.

loopglobal
Novice

Re: ZipArchive need to be enable

Thank you very much. Yes I have cpanel hosting.Just followed your steep and successfully installed. Thanks a lot for this help. appreciate it

greg2hype
Novice

Re: ZipArchive need to be enable

I had the same issue did the same install now I get this message in Wordpress still "Important: You need to activate zip extension." also on the pear page shows "

You will need to add “/home/greg2hype/php” to the include path. You can do this by adding the following code to your script:

ini_set("include_path", '/home/greg2hype/php:' . ini_get("include_path") );"

 

not sure what else to do but it won't work still says I need to do this activate???

Moderator
Moderator
Solution

Re: ZipArchive need to be enable

Hey @greg2hype. Welcome to GoDaddy Community!

 

If you have a cPanel account, I'd recommend trying to add the zip extension on the "select PHP version" page. You should be able to just put a check mark by 'zip' and then save. You may need to restart your PHP processes for the change to take effect through. 

 

JesseW - GoDaddy | Community Moderator | 24/7 support available at x.co/247support | Not currently moderating - see Mod Schedule.
martynbush
Novice

Re: ZipArchive need to be enable

Thank you. Big help.

layman
Novice

Re: ZipArchive need to be enable

after installing the zip, i am getting the same issue, can you please explain the next step as i need to something in c panel or need to restart something

baggio
Novice

Re: ZipArchive need to be enable

First I installed the zip as 

 

ahmadgfx
Novice

Re: ZipArchive need to be enable

i did as you say but it's not work!

help me plz

theJCpro
Novice

Re: ZipArchive need to be enable

Go To:

Web Hosting - - click - - MANAGE

Software - - click - - Select  PHP Version

In the columns below, ensure that "zip" tab is checked (selected).

Click - - SAVE.

 

Go back to SOFTWARE - - click - - PHP Processes - - click - - KILL PROCESSES

 

That should do it. It worked for us. Hope this helps.

Nectareon
Novice

Re: ZipArchive need to be enable

What to do enable the zip_open() on server shared hosting .. i have installed opencart system.. when i tried to upload.ocmod files through extension installer.. i got error as undefined function call zip_open..

Nectareon.com
Avibm
Novice

Re: ZipArchive need to be enable

Excellent! Great job at helping us to understand and get it done. You saved me a lot of time waiting for customer support. Really, Thx!

naktha
Novice

i Re: ZipArchive need to be enable

Hi 

 

there is no option for PHP version under the software . please help where i can find it  

Re: ZipArchive need to be enable

Please enable ZipArchive

Re: ZipArchive need to be enable


loopglobal wrote:

Hello,

 

I have purchased a theme from themeforest and installed and I see this notice.

 

ZipArchive
 
Not installed - ZipArchive is required for importing content. Please contact your server administrator and ask them to enable it.
 
So please install this so that I can enable this.
 
thanks


Please enable ZipArchive

ShakirKazi
Novice

Re: ZipArchive need to be enable

For latest PHP version 5.6 1 Got Main Cpanel page 2 Click "PHP version" link from software section athe bottom of page 3 now list of module;es will be displayed 4 select Zip 5 Click on save
PCH88
Skilled

Re: ZipArchive need to be enable

I installed the ZipArchive as per jvanderb's instructions. It appears that it installed correctly on the server, but my WordPress site still does not detect the install. I went back to the PHP Pear site and now I have the following message saying:

 

You will need to add “/home/patriciahost/php” to the include path. You can do this by adding the following code to your script:

ini_set("include_path", '/home/patriciahost/php:' . ini_get("include_path") );

 

What script file am I supposed to add this to?

PCH88
Skilled

Zip Archive needs to be enabled - New Post

I bought a WordPress theme, that was requesting that ZipArchive be installed. So I followed the instructions in a previous post. It appears that it installed correctly on the server, but my WordPress site still does not detect the install. I went back to the PHP Pear utility in my cpanel and now I have the following message saying:

 

You will need to add “/home/patriciahost/php” to the include path. You can do this by adding the following code to your script:

ini_set("include_path", '/home/patriciahost/php:' . ini_get("include_path") );

 

Inside what script file am I supposed to add this line of text? And would that line of text fix my issue of my WordPress site not detecting that I installed ZipArchive?

Re: Zip Archive needs to be enabled - New Post

i'm facing exactly the same issue.  What is absolutely ridiculous is that Godaddy support is clueless about this issue themselves and don't have means to have a screen-sharing during the call.  Criminal waste of customer's time.

unicorn
Novice

Re: ZipArchive need to be enable

It would be nice if you would be more specific at what particular script/or file? you are talking about.

PhArObiS
Novice

Re: ZipArchive need to be enable

Followed everything on this post.  It actually says its installed, but yet still get this error on user exports. 

 

"ZipArchive class is missing on your server.
Please contact your web hosting provider and ask them to install and activate ZipArchive"

 

What the heck?

Re: ZipArchive need to be enable

Thank you...my theme is now working!

mjgarro93
Novice

Re: ZipArchive need to be enable

Hello!! I did the two steps but when I try to install the pluging with the slider shows me the same mistake again... Smiley Frustrated

 


JesseW wrote:

Hey @greg2hype. Welcome to GoDaddy Community!

 

If you have a cPanel account, I'd recommend trying to add the zip extension on the "select PHP version" page. You should be able to just put a check mark by 'zip' and then save. You may need to restart your PHP processes for the change to take effect through. 

 


 

fdarko
Novice

Re: ZipArchive need to be enable

Great just worked for me. After installing Archive_Zip. I had it enable under "PHP Version" in Cpanel

fdarko
Novice

Re: ZipArchive need to be enable

Great just worked for me. After installing Archive_Zip.

I had it enable under "PHP Version" in Cpanel

Mohit_Mits
Novice

Re: ZipArchive need to be enable


jvanderb wrote:

What kind of hosting do you have?  Do you have a shared linux host, and have access to cPanel?

 

If so, you should be able to do this yourself.  Just log in to your cPanel, and click on the icon labeled "PHP PEAR Packages" (in the Software section).  Next, in the search box (underneath the "Find a PHP Extensions and Applications Package" heading, type in "zip" and click the Go button.  On the next page, you should see a listing for Archive_Zip - simply click on the Install link on the right hand side.



Hi,

 

I am trying to import a slider and tried installing zip archive with the solution suggested. However, I am getting the below error:

 

Completed
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20100525/imagick.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20100525/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0
therdchat
Novice

Re: ZipArchive need to be enable

thank a lot.very easy you guide 

andrewmarna
Novice

Re: ZipArchive need to be enable

Awesome! it worked

Re: ZipArchive need to be enable

Thanks fixed my issue.

mankav
Tinkerer

Re: ZipArchive need to be enable

Hello,

I have the same problem.

after on zip mode it is not going to save.

Re: ZipArchive need to be enable

Thanks alot, great help.

pramil
Novice

Re: ZipArchive need to be enable

This worked for me.

RameshK
Novice

Re: ZipArchive need to be enable

Worked for me! It was a quick fix. Also learned how to add additional extensions for php in godaddy hosting!

student
Novice

Re: ZipArchive need to be enable

I followed all of the instructions and when I got to the part of typing in the search box the word "zip" the results returned : No Modules matched your search terms.

 

I am wondering what this means? I'm a newbie.

sward
Novice

Error: #U205, PHP ZipArchive support is not enabled!

I know this has been posted before I searched the archive but the answers did not help.

 

I am on a Virtual Server what if my C panel dashboard does not list Select PHP Version  under software?

 

I need to update my WPL software( A real estate WP data-base update) and I don't want to overwrite anything; I get

"Error: #U205, PHP ZipArchive support is not enabled!"  But I can't for the life of me find where to turn it on. PLEASE HELP

 

The only related Icons I have on my C panal are two:  It has PHP and PHP Pear packages but in  'PHP' icon  it says 'These PHP configuration settings are customizable by the server administrator. They are listed for reference only.'

 And PHP PEAR says: 

“PHP Extensions and Applications Package” Installer

PEAR packages are collections of functions that allow you to perform tasks in PHP. You will need to install a PEAR package before you can use it inside a PHP program. Note: Packages are installed directly from the PHP Extensions and Applications repository (PEAR).

Checking Setup

Updating channel "pear.php.net"
Channel "pear.php.net" is up to date

        
fessuoy
Novice

Re: Error: #U205, PHP ZipArchive support is not enabled!

I do not find "Select PHP Version" in my Cpanel (Software Part).

Anything changed ??? or should i look for it somewhere else ?

pramil
Novice

Re: Error: #U205, PHP ZipArchive support is not enabled!

The option to select the PHP Version is still there.

Maybe it depends on the Hosting Plan that you're using.

I'm using the Linux Ultimate plan and the option is still available for me.

 

You can contact the Support team for more info.

Re: ZipArchive need to be enable

my issue still hapaned