cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Highlighted

How to enable parent paths in IIS for classic ASP site

I'm moving a classic ASP site from dedicated hosting with IIS 7 to shared hosting that uses Plesk and IIS 8, so the only control of IIS is via a few settings in Plesk.

 

How can I enable parent paths for ASP ? do I use web.config or some other method ??

 

thanks !

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Solution

Re: How to enable parent paths in IIS for classic ASP site

Ok, amazing I found the fix.

 

In the new Plesk panel, you go to VIrtual Directories and then click on Directory Properties.

Then check the box "Enable Parent Paths' then save.

 

It worked!

View solution in original post

3 REPLIES 3
Highlighted
Moderator
Moderator

Re: How to enable parent paths in IIS for classic ASP site

Hey @metafizx

 

First let me say welcome to the community! Smiley Happy

 

Not sure what you mean by enabling the parent path. Are you perhaps referring to the absolute path which should already be present within all Plesk hosting plans.

 

If I misunderstood, perhaps you can elaborate further on what it is you're specifically trying to accomplish within this Classic ASP site? Having a better idea of what functions you're needing to utilize may help other members familiar with what you're attempting to do offer some more suggestions. 

 

CG - GoDaddy | Community Moderator
24/7 support available at x.co/247support
Highlighted

Re: How to enable parent paths in IIS for classic ASP site

thanks for your reply.

Plesk used to have an option to allow Parent Paths for classic ASP code, but apparently it is gone.

 

I have tried setting it with web.config but it doesn't work.

 

So unfortunately what is working currently on dedicated server with GoDaddy will not work in shared hosting.

😞

Highlighted
Solution

Re: How to enable parent paths in IIS for classic ASP site

Ok, amazing I found the fix.

 

In the new Plesk panel, you go to VIrtual Directories and then click on Directory Properties.

Then check the box "Enable Parent Paths' then save.

 

It worked!

View solution in original post