Skip to main content
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Please help - wp_postmeta table not getting updated after migrating wordpress to cpanel (no images)

I migrated my 6-month old wordpress site from a godaddy legacy server to the deluxe cpanel hosting service. Now the existing images that were on the site before still load okay, but I cannot see or manipulate any new images via the media library - I don't get an error message, I see the progress bar as it "uploads" the image, but then I just get a grey box where the image should be. I cannot add the image to either a new or existing post using the wordpress editor.


If I go in to edit the new images, I can see that the "file name" and "file size" fields are empty (these have names for the older 'working' images). However, the url field does contain a link that leads to the uploaded image, which has been uploaded to where I would expect it to be (i.e. in .../wp-content/uploads/2018/08/image.jpg). So the image is getting uploaded, but wordpress won't generate thumbnails and I can't use it.


So far I have tried without success

- disabling all the plug-ins

- trying different sizes and sources of images (all <1Mb)

- different browsers

- changing the permissions of the wp-content/uploads folder (set at 755, also tried 777 and 744)

- running the force thumbnail regenerator plug-in

- different PHP versions, as well as increasing the memory limit, post_max_size and upload_max_filesize

- creating a new administrator account

- reinstalling wordpress


I am at a loss regarding what else I can do. Please, please, can anyone help identify the issue?


Edited to add update: Attachments are being uploaded  to the wp_post table, but for some reason the wp_postmeta table is not getting updated at the same time? This is presumably why I can't see any images on the site. But I still don't know why or how to fix it.


Hi @daisyb,


Thanks for posting. You'll need to confirm that WordPress is trying to upload media to the proper folder and that folder has the correct permissions, you can do that following the steps in this guide. Or you can also contact live support so they can review the server's permissions. Hope that helps!


Lisi - GoDaddy | Community Moderator | 24/7 support available at | Remember to choose a solution and give kudos.

Thank you very much for replying @Lisi. Unfortunately, as I noted in my message, I have already checked permissions and folders etc (and have followed all the steps in the guide you kindly linked), but this is not the issue. I have also contacted live support, who were not able to determine why it was happening either.


With further digging I have been able to determine that images and other attachments are being uploaded fine to the wp_post table (I can view them through the appropriate url), but the wp_postmeta table is not getting updated, which is why they are not showing up on the website.


If anyone has any ideas why the wp_postmeta table might not be getting updated I'd be very very grateful for suggestions!