Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

CPanel server bash commands not found

I am using CPanel linux hosting for my site and I am trying to install nodejs on my server so I can keep an instance running to handle a particular http request.  After sshing into my server the first thing I tried was "sudo apt-get install nodejs" but I recieved the error "-bash: sudo: command not found".  I have tried every command that I can think of that is relevant to installing packages (sudo, su, apt-get, yum, rpm, etc.) and all of them respond with "command not found".  My path is set up correctly, but the commands are nowhere to be found.  Currently the only way I think that I can install nodejs on my server is by using wget to download the source and then compiling it on the server.  Is there any way to enable the use of all/any of these bash commands to make my life easier?

Helper V
Helper V

Re: CPanel server bash commands not found

@ebacdc3 If you are ising Shared CPanel linux hosting then you do not have Root access to the server. Your account is chrooted to your home directory and only have limited access to commands. You will not be able to run Node.js. It may be against TOS to run other programs from a shared hosting account but not sure. You will need to upgrade to a Cloud/VPS/Dedicated Server to use Node.js



Re: CPanel server bash commands not found

Alright, that makes sense.  Thank you.